1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

ford truck problem

Discussion in 'Ford Trucks' started by Scenic Lawnscape, Feb 15, 2007.

  1. Scenic Lawnscape

    Scenic Lawnscape Senior Member
    Messages: 481

    Ok it has been along time since i posted on here, but i just bought a 1990 f-250 4 x 4 with a 302 and a aod trans (auto) The problem i am having is when it is idiling it runs "great" and when i first take off it is hell on wheels, when i get up to speed around 40 or so and i go to punch it (to pass some one) it feels and acts like i am towing a 20 ton trailer, it just takes for ever to pass, the trans doesnt slip, the rear end is good. I am thinking that the cats are clogged, what do you guys thinks

    Thanks for the help
     
  2. tsmith

    tsmith Senior Member
    Messages: 255

    I would agree with you, my 95 acted the same way and it was the cat
     
  3. f250man

    f250man PlowSite Veteran
    Messages: 3,124

    Well if you run it hard and get it good and hot and look under the truck and it is red hot and smells like rotten eggs it is clogged. Steve
     
  4. tsmith

    tsmith Senior Member
    Messages: 255

    You can get under there and take out one of the pre-cat o2 sensors to let it breath and see if it gets better, if so it's the cat.