1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Food For Thought....

Discussion in 'Chevy Trucks' started by Razzlo, Feb 19, 2001.

  1. Razzlo

    Razzlo Member
    Messages: 33

    Replaced the plugs on my truck ('84 C10/350)a couple of weeks ago, and everything was fine. I has sent a post to this group ,needing help to locate the timing indicator. it turns out that when the engine was rebuilt, the indicator was never re-installed. Anyway, Yesterday, i was trying to adjust the idle etc., and the engine started running rough like it was missing. Not knowing what to do, I figured it was a vacuum problem. After HOURS AND HOURS of trying to solve the problem, I broke down and took the truck to the mechanic this morning. Well... $200 later... They said that I had 2 broken plugs. DUH!!!!. That was the first thing I thought, but did I chek them???? NO!!!. I figured, heck, I just replaced them a couple of weeks ago. I even had the timing light out and could have checked for spark on each plug BUT NO!!!!!!. Anyway, just wanted to share. At least the truck purrs like a kitten now. BTW, There was a vacuum leak, and there was no Dist. Adv. or EGR, so it was worth the money. Next time I will be a good boy and consult this list.... I just wonder how they set the timing without a timing mark....

  2. 75

    75 PlowSite.com Addict
    Messages: 1,382

    Glad to hear it's running, and running well. I took a look at my reply to your timing mark question, I never thought about the timing tab being gone. Food for thought there too!

    1975 GMC C-35
  3. Razzlo

    Razzlo Member
    Messages: 33

    Just as a follow-up, I picked up the wreck, and it now purrs like a kitten...for now... Sometimes it helps to have someone else look at the problem.