1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher problems

Discussion in 'Truck & Equipment Repair' started by ImpressPlowing, Oct 21, 2012.

  1. ImpressPlowing

    ImpressPlowing Member
    from NYC
    Messages: 58

    hey guys i have a fleet of Fisher plows
    Last year on one of the plows the controller was acting crazy
    you hit left it when up
    right doesnt work
    i replaced the solinoids, i only used the plow once last year,
    its happening again, any ideas?
     
  2. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    Try a different controller.
     
  3. ImpressPlowing

    ImpressPlowing Member
    from NYC
    Messages: 58

    Tried that already
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    So a new controller on that plow didn't fix it?
     
  5. ImpressPlowing

    ImpressPlowing Member
    from NYC
    Messages: 58

    Nope I'm thinking module
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Did you try that plow on a different tk? Try swapping out stuff before buying anything
     
  7. ImpressPlowing

    ImpressPlowing Member
    from NYC
    Messages: 58

    Yup works fine on other truck
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Ok. And another plow on that tk?
     
  9. ImpressPlowing

    ImpressPlowing Member
    from NYC
    Messages: 58

    Same prob, so it's gotta be somewhere between control and plow hookup
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Ok. Did you test light the outputs without the plow hooked up? At the controller plug, in and outta the ISO?
     
  11. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    sounds like a bad plug/connection somewhere on that truck
     
  12. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    That's kinda what I was thinking as well. Just fishing for more info
     
  13. durafish

    durafish PlowSite.com Addict
    from 02919
    Messages: 1,092

    I had the same issue its the control wire on the plow coming from the motor. Easy fix about $80.