1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher Polycaster

Discussion in 'Fisher Engineering Discussion' started by snowsux, Dec 19, 2011.

  1. snowsux

    snowsux Junior Member
    Messages: 5

    Tonight we're expecting a flash freeze. We load up our Polycaster which is one year old and now it won't spin and the conveyor won't move. The control lights up like the unit is empty. Any ideas??? oh, and we just broke a leaf spring to add insult to injury.
     
  2. MIDTOWNPC

    MIDTOWNPC PlowSite Veteran
    Messages: 4,452

    Does the controller flash a pattern?
     
  3. MIDTOWNPC

    MIDTOWNPC PlowSite Veteran
    Messages: 4,452

    I keep this on my phone in an email just incase

    Number of Flashes Problem Possible Cause

    0 No Fault –

    1 No Communication Loss of communication between spreader module and cab control.

    Vehicle cable assembly is disconnected or faulty.

    2 No Material Flow Spreader is empty or material has bridged in the hopper.

    3 Excess Current Over 80 amps for 1 – 2 seconds.

    Conveyor belt is stalled.

    4 No Power Battery fuse is blown, or vehicle cable assembly is disconnected or faulty.

    5 Over Heated Motor is off due to spreader module over heating.

    Possibly due to excessive current draw or poor thermal contact between spreader

    module and conveyor sill.

    6 Low Voltage Low battery voltage or poor electrical connection of vehicle cable assembly.
     
  4. snowsux

    snowsux Junior Member
    Messages: 5

    Flashes every second and beeps. Worked perfectly until tonight.
     
  5. MIDTOWNPC

    MIDTOWNPC PlowSite Veteran
    Messages: 4,452

    I had it happen to me at the start of the season. The batteries were low in the truck and I let it charge up a bit after sitting all summer basically and it worked after ten mins
    Unplug the connection clean them with some airintake cleaner or electronic cleaner and then put them back together. Electric grease them after they work.

    if the chain is seized it won't spin. Try it without the chain.
     
  6. MIDTOWNPC

    MIDTOWNPC PlowSite Veteran
    Messages: 4,452

    Count how many. There will be a pause. That's the break and you will know how many. I'm betting six
     
  7. snowsux

    snowsux Junior Member
    Messages: 5

    Thanks for the ideas....it just beeps every second and flashes..no pause...counted up to 20. hhmm
     
  8. MIDTOWNPC

    MIDTOWNPC PlowSite Veteran
    Messages: 4,452

    This is the new version. Two motors. Rounded plastic?

    Mine is the older style

    It thinks it's jammed? Can you remove power and move it with a wrench?
     
  9. MIDTOWNPC

    MIDTOWNPC PlowSite Veteran
    Messages: 4,452

  10. snowsux

    snowsux Junior Member
    Messages: 5

    thanks for the ideas. was faulty terminal at battery. now to fix the leaf spring.
     
  11. snowsux

    snowsux Junior Member
    Messages: 5

    Ya, mine is the newer style. Thanks a lot for the help.
     
  12. MIDTOWNPC

    MIDTOWNPC PlowSite Veteran
    Messages: 4,452

    No problem.
    Been there done that. Lol.