1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher Poly Cast (new style) Not working

Discussion in 'Truck & Equipment Repair' started by Tylerlawncare, Dec 8, 2014.

  1. Tylerlawncare

    Tylerlawncare Member
    Messages: 38

    I bought a Fisher ploy cast 1.8 sander a couple of months ago and have finally hooked it up. The problem is is does not work. When you turn it on it just beeps and flashes red. I have tried counting the number of beeps to see what code it is, but it does not pause, it just keeps beeping.. Has anyone had this problem?
  2. CMD

    CMD Member
    from Maine
    Messages: 40

    Open the rear gate to 3" to reduce torque , start drag chain slow and increase speed to suit product
  3. Tylerlawncare

    Tylerlawncare Member
    Messages: 38

    There is nothing in the hopper, just hooked it up and then you turn it on it just beeps
  4. cubplower

    cubplower Senior Member
    Messages: 182

    go through and check all connections from your battery all the way to the back of the sander
  5. AG09

    AG09 Senior Member
    Messages: 159

    Check both the male and female side of the 4 pin connector in the back. It may have corrosion or a pin isnt making good contact.
  6. Hysert

    Hysert PlowSite.com Addict
    Messages: 1,205

    Or contact Dave "mishnick" they are vary simple units ive had 3... is it a new unit to you???
  7. all ferris

    all ferris Senior Member
    Messages: 118

    I would say that you either have a bad electrical connection or your drag chain or spinner is frozen/rusted/bad bearing.
  8. BMWSTUD25

    BMWSTUD25 Senior Member
    Messages: 630

    In my experience non stop beeping is actually just one beep that sounds almost continuous.