1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher plow wont raise

Discussion in 'Fisher Engineering Discussion' started by 90plow, Oct 23, 2013.

  1. 90plow

    90plow Senior Member
    Messages: 737

    My 2008 x blade angles left and right fine but going up it sounds like its really working hard and only lifts partway. It really has gotten bad since adding the prowings now its reallly having a hard time. I replaced the motor last weekend and moved it to another truck still has the same symptoms. Ive tried adjusting the quill for the drop speed all the way in all the way out half way etc still doing it. Is it the pump?
     
  2. gtmustang00

    gtmustang00 Senior Member
    from Berlin
    Messages: 747

    I'm willing to bet it's the pump...Unhook the hose going to lift piston and pressure test it.
     
  3. 90plow

    90plow Senior Member
    Messages: 737

    What kind of guage do i use?
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    It's prob the pump. But for grins. When's the last time you did fluid and filter ?
    Psi gauge that goes at least to 2000psi
     
  5. 90plow

    90plow Senior Member
    Messages: 737

    The end of last season when i started having the problem
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    So at the end of last season you started having issues and that's when you changed filter and fluid. What did the filter look like? What did the fluid look like?
     
    Last edited: Oct 24, 2013
  7. 90plow

    90plow Senior Member
    Messages: 737

    Filter and fluid were fine i pulled the filter but it probably didnt even need to be changed.
     
  8. 07PSDCREW

    07PSDCREW Senior Member
    Messages: 863

    I had that issue when I was low on fluid.... Had a leaking packing nut that I didn't know about.