1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

fisher plow not working

Discussion in 'Fisher Engineering Discussion' started by meyer22288, Nov 24, 2014.

  1. meyer22288

    meyer22288 Senior Member
    Messages: 999

    at work we have a 2012 f350 diesel with an 8ft fisher straight blade plow. I hooked the plow up and nothing. no lights at all. the controller don't light up. its a joystick controller. I have no idea whats wrong. its 2 plug system. I am getting power to the pump but again no lights or controller. any ideas?
     
  2. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    Check the fuses under the front cover on the plow...
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,976

    Anything recently done to the trk?
    And yea Ck the fuses
     
  4. meyer22288

    meyer22288 Senior Member
    Messages: 999

    those 4 amp fuses are good. nothing I know of its our fert truck in the summer and does a lot of miles but to my knowledge nothing besides maintenance.
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,976

    Is it a fleet flex model?
     
  6. meyer22288

    meyer22288 Senior Member
    Messages: 999

    what exactly is fleet flex?
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,976

    New electrical plow wiring
    How many pins at the controller connector inside the cab
     
  8. meyer22288

    meyer22288 Senior Member
    Messages: 999

    4 pins. its the newer style fisher its different then our 2011 fisher but same as our 2014 fisher we just picked up.
     
  9. meyer22288

    meyer22288 Senior Member
    Messages: 999

    I spent 6 or so hrs on this today with no success. im not getting power the the 11 pin harness that works the lights and controller. all fuses are good all grounds and conections are good wires are all in good shape. im stumped. this needs to be running tomarrow and I don't know what else to do. the only thing left is the isolation modual but I don't think that could be the issue. :help:
     
  10. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    The controller fuse under the hood by the isolation module is good? Check the two four-pin weather pack connections on the control harness... one plugs into the lighting harness, and the other into the battery cable. Is this an existing setup, or a new install? If existing, has anything been unplugged, or moved around, during the off season? Or did it just not work when you hooked it up?
     
  11. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    Does the lights work on truck and do they work on the plow?
     
  12. meyer22288

    meyer22288 Senior Member
    Messages: 999

    truck lights are fine but I have no plow lights at all. it was dealer installed in 2012. all plugs are good I went threw them all. its possible things got moved around during the off season the truck works everyday as our fert truck.
     
  13. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    it actually could be the module or you have a bad ground somewhere
     
  14. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    Check that the two four-pin plugs in the control harness are in the correct locations. The one at the very end of the control harness goes to the battery cable, and the one that's broken out of the middle of the control harness goes to the lighting harness. You said things may have gotten moved around. Not sure if it's possible that they got switched somehow, but the plow won't operate if they're reversed.
     
  15. meyer22288

    meyer22288 Senior Member
    Messages: 999

    Everything is labeled from factory and in its correct location i checked that to.
     
  16. meyer22288

    meyer22288 Senior Member
    Messages: 999

    Plow is fixed. Had to replace the 11 pin harness