1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher plow lights

Discussion in 'Truck & Equipment Repair' started by al45target, Jan 25, 2012.

  1. al45target

    al45target Junior Member
    Messages: 11

    When I posted the last question, don't think I was too clear. Have a 2500 Silverado, HD 8' Fisher. When I mounted the plow for a storm the drivers side low beam doesn't work. (Worked about a month before). Anyway checked the wiring, replaced bulb, checked harness fuses. Cleaned the 11-pin connection. Nothing seems to work. The low beam on the truck works. Any help would be great as we might have more snow this Sat.-Sun. Took it to where I bought the plow and he seems stumped too. Here's hoping we have a LOT of snow. Al
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,949

    Does this have an ISO module?
     
  3. al45target

    al45target Junior Member
    Messages: 11

    It does have a ISO module. Al
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,949

    Double ck the plow light harness where it plugs into the truck light harness, make sure that the a or b side of the connector is in its proper place.
     
  5. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,621

    Make sure all the connectors for the headlight harness are on the same side. They should have an A and B on them, these are the plugs your stock headlight connectors plug into.


    Edit

    Too slow, Diesel beat me to it.
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,949

    Lol. Just glad someone else replied back to verify my cking procedure.
     
  7. al45target

    al45target Junior Member
    Messages: 11

    Thanks to all that replied. Going to go out and try it now. Let you know how AI make out. Again, thanks.
     
  8. al45target

    al45target Junior Member
    Messages: 11

    Still no luck. Rang out the low beam wire, light blue, from the headlight to the Isolation Module and wire is good. Could it be the Module? I have a 11 pin harness. Al Still talking about the drivers side low beam.
     
  9. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,949

    Is the plow plug at the truck lights plugged in in the right way?
     
  10. allen81

    allen81 Member
    Messages: 97

    Al,

    Do you have a configuration plug that is in the area near where the 2 fuses are for the plow harness?
     
  11. allen81

    allen81 Member
    Messages: 97

    Al,

    Go to the following link http://library.westernplows.com/ddcommon/dd_pdf/pdfs/22373.07_110108_for_web.pdf and go to page 4. I am not sure what kind of bulbs you have in your truck. But for me I had to configure everything to HB-1 as that's what my truck is. I had to change the wires on the blue head light connector on both sides and then I had to change 2 wires on the iso connector so that it is configured for HB-1 My harnesses were originally configured to HB-5. Now my problem still exists so now I am waiting for the guy to give me another short plug in harness on the driver side as the fisher dealer that the harness that goes into port 3 is bad I hope that will fix my problem. I am so sick of this issue I think I have been trying to fix this issue for a few weeks now.
     
  12. al45target

    al45target Junior Member
    Messages: 11

    Morning guys. Reference the plow plug. Yes it is as the Fisher plug can only be plugged in one way. The mystery come from the fact that everything worked during the Oct. storm, then plugged things in for our Jan. storm and the left low beam didn't work. I have checked all the fuses, rang out wires looking for a short, Looking a a wiring diagram that I downloaded, Could it be the Low beam headlamp relay? Keep on truckin, Al
     
  13. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,949

    ok,,going to have to start cking for pwr and gnd at connectors. ck it at the truck, ck at the iso in and iso out.
     
  14. leolkfrm

    leolkfrm PlowSite.com Addict
    Messages: 1,408

    make sure a wire has not backed out of the connector but looks good...confirm power before and after any connection