1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

fisher mm1 plow problems

Discussion in 'Fisher Engineering Discussion' started by aaron03, Nov 3, 2012.

  1. aaron03

    aaron03 Junior Member
    Messages: 15

    hi guys, i have a mm1 one with and electric hydraulic pack on it 3 plugs system, i changed the fluid and bleed all the air out of the system about a month ago and today went to move the plow and have no functions at all. plow is mounted on an 03 gmc sierra 2500hd. any help would be greatly appreciated
     
  2. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    does the red light on the controller light up when you hook up the plow?
     
  3. aaron03

    aaron03 Junior Member
    Messages: 15

    yes, it does
     
  4. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    OK so it sounds like your getting power from what I know, does the plow make any noise? any noise at the selnoid?
     
  5. aaron03

    aaron03 Junior Member
    Messages: 15

    plow pump makes noise like its gunna pick it up but it doesnt pick it up of move left to right, i can say this i picked up another plow for a buddy with my truck and it all worked, i also have a spare controller i tried and it was doian and making same sounds.
     
  6. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    Ok hate to say it but maybe the plow motor is stuck or starting to go? I would check your selnoid connections on your truck too.
     
  7. aaron03

    aaron03 Junior Member
    Messages: 15

    ya im gunna test the selnoid in themoring when i have more day light
     
  8. aaron03

    aaron03 Junior Member
    Messages: 15

    i also cleaned all plow connections on plow side and truck side and regreased
     
  9. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    good idea, do the plow lights work?
     
  10. aaron03

    aaron03 Junior Member
    Messages: 15

    yes plow lights work
     
  11. aaron03

    aaron03 Junior Member
    Messages: 15

    you were right man i tested the motor today and it is junk, order new one already with the gaskets and everything should be in sometime this week
     
  12. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    yeah, it happens

    good luck
     
  13. aaron03

    aaron03 Junior Member
    Messages: 15

    ok so ive changed my motor on my plow and also had to chabge the s2 cartride after bench testing in to see it was no good, but i still have no function up down left right, could it possiably be the plow pump
    thanks aaron
     
  14. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    What motor did you change?
     
  15. aaron03

    aaron03 Junior Member
    Messages: 15

    the plow motorthat site left of the lift ram
     
  16. aaron03

    aaron03 Junior Member
    Messages: 15

    the plow motor that sits left of the plow lift ram
     
  17. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    oh ok, you might want to check the valve connections make they are correct?

    Also check you solenoid connections make sure they are correct. Is your controller fully functional?
     
  18. aaron03

    aaron03 Junior Member
    Messages: 15

    I bench tested all the solenoid catradges and my s2 valve was junk replaced it . I have full power at the controller just no functions.
     
  19. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    It is possible u have a bad controller
     
  20. mksent02

    mksent02 Member
    Messages: 37

    Sounds like you're not pumping fluid. Hard to diagnose by reading, Does the motor sound normal? make sure it engaged the pump. then I would look into the pump assy. itself.