1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fisher MM1 Ez V motor runs no movement

Discussion in 'Fisher Engineering Discussion' started by Gmiller, Dec 1, 2015.

  1. Gmiller

    Gmiller Junior Member
    Messages: 14

    Hey all.

    I've had this mm1 Ez-v for two seasons now. Last season it gave me hell with the hoses, they would brake and blow fluid while plowing. My stupid mistake was finally figured out when i realized my plow a-frame was coming in contact with the hoses when i would push into a pile. I made a stop so the a-frame will stop before hitting the hoses. All new hoses and fluid at the start of the season. No issues this season with hoses.

    Yesterday morning it was cold. My employee went to go start plowing and plow wouldn't move. Motor runs with every button i press but plow won't move anywhere. Controller is new and motor is new and has power. Did it freeze up? I guess ill tear into it. Let me know your thoughts
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    Pull the motor off, easy enough.
     
  3. Gmiller

    Gmiller Junior Member
    Messages: 14

    Frozen. All fixed up.
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    Drain everything? Rams, lines, etc....