1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

fisher ez vee with mode control was working then stopped.

Discussion in 'Truck & Equipment Repair' started by mtnzone, Dec 9, 2013.

  1. mtnzone

    mtnzone Member
    Messages: 82

    ok here is deal got the plow ready for season the last thing I did was fill reservoir up. everything was working just fine angle up down vee you name it. had a small snow fall and went out to do some driveways did my driveway well backdragged it and forgot something so lifted plow and moved forward put it down and parked went inside and wife had a few honey dos to do as well. when I went out to proceed again I started truck lifted blade and commenced to finish my driveway but the plow wouldn't move. Stayed in up right position but wouldn't angle wouldn't scoop wouldn't flare back. so I tried dropping it of course that work now nothing. so there it sits. I only have a few driveways to do and of course this is first storm so the bugs are there need to get this fixed any ideas.

    I played with controller and heard the motor working just fine . do you think there is air in it? if so easy way to fix?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Pull the fill cap and see where the level is. Might just be low. How many quarts did u use?
     
  3. mtnzone

    mtnzone Member
    Messages: 82

    Actually figured it out... for some reason I must have some water in the resevoir I dont know how as i changed the fluid recently. Anyways I had frozen slush which was clogging my pumpand filters so the plow wasnt getting any fluid. all fixed now!!!