1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fished MM1 shuts off -please help!!

Discussion in 'Truck & Equipment Repair' started by gtstang8706, Oct 30, 2011.

  1. gtstang8706

    gtstang8706 Member
    from MA
    Messages: 36

    Ok, so I was plowing the freakishly early October blizzard this morning and all seemed to be working fine. I went to turn the blade and noticed the fish Stick was off. I turn it back on and try to move the blade but all I get is a click from under the hood and the fish stick shuts off again. I Checked all the connections, tried a diff fish stick, but still nothing. Any help with this issue would be greatly appreciated! It's too early for plow issues already!
     
  2. equip guy

    equip guy Member
    Messages: 38

    Do you have power to the red wire that the fishstick plugs into?, there should be a wire going to your fuse box that is suppose to be only powered up when you turn the key on. Check to make sure it is connected or the fuse it id tapped into isn't blown, this should be a red wire comming out of the braided harness and is routed to fuse panel under/side dash.
     
  3. gtstang8706

    gtstang8706 Member
    from MA
    Messages: 36

    Hmmm I'll check it first thing in the morning. I've never had this issue before. Any ideas why it would suddenly occur?
     
  4. gtstang8706

    gtstang8706 Member
    from MA
    Messages: 36

    Just checked out the red wire- looks fine, fuse is not blow either. I tried jumping the 2 posts on the solenoid and having someone hit the control, did nothing. When I touched the 2 posts together there was no power at all to the fish stick. Solenoid just keeps clicking. I'm friggin lost! Anything else?
     
  5. gtstang8706

    gtstang8706 Member
    from MA
    Messages: 36

    Replaced solenoid, still nothing . Tried a different fish stick-nothing. Disconnected the plow from the truck and hooked it up to my other truck and it' works fine! So I now know that it's an issue with the truck side. I know it's not the fish stick or the solenoid, what's next? I did notice that when I flip on the headlights I lose all power to the fish stick....
     
  6. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    you have a bad connection somewhere. unplug the fishstick and see if there is power going into the plug. i have seen the fuse holder fail numerous times. check for power out of the fuse with and without the lights on.