1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Fish Stik problem?

Discussion in 'Fisher Engineering Discussion' started by PeteB4, Jan 2, 2014.

  1. PeteB4

    PeteB4 Member
    from Maine
    Messages: 56

    Not sure if the issue is with the controller or not. Occasionally I cannot get the blade to lower. Raises no problem, angles L, R without issues. Once in awhile, though, it will not lower. Then it will drop after a little bit (30 - 90 seconds). Then it works fine. Did it 3-4 times tonight. There is no click on the down button when it does this. Other buttons do click. When down works, it does click.

    When I started out earlier today, the motor did whine a bit until "warmed up."

    Any thought would be helpful.

    I don't have a spare controller, so I can't just swap to check.

    Thanks.
     
  2. ScubaSteve728

    ScubaSteve728 Senior Member
    Messages: 477

    clean check and grease all of your plugs from the plow to the truck and inside the truck to the controller then grounds on plow and in truck and on solenoid
     
  3. PeteB4

    PeteB4 Member
    from Maine
    Messages: 56

    Thanks, Steve. Will do that and let you know. Appreciate the reply.
     
  4. jshocik

    jshocik Member
    Messages: 42

    I've heard of problems with the fish stiks, & the best bet is to buy a back-up. I bought a used one on eBay. I'd try to find someone with a known good controller & try that one out.
     
  5. PeteB4

    PeteB4 Member
    from Maine
    Messages: 56

    Truck side control harness had broken wire.