1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

fish mm electircal issues

Discussion in 'Truck & Equipment Repair' started by bgingras, Oct 30, 2005.

  1. bgingras

    bgingras Senior Member
    Messages: 282


    just hooked up the MM that came with my truck for the first time today. It hited up fast but when it came time to raise, nothing...just a click from the solenoid...after testing all contacts I came to conclusion that the wire connecting to the side of the motor was not delivering enough current.,..after I cleaned and reconnected, it worked for about 10 seconds and then nothing..this time I had to clean the ground and now it seems ok...BUT how do you prevent having to do this proceedure...the connections are right out in the open with no protection...are there covers people use or what?

    Other than that, the MM went on and off real smooth..once I realized to lower the headgear completely before disconnecting it.
  2. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

    Get some dielectric grease from the parts store and grease your connections once they are clean,make it a habit every now and then and you should be set.
  3. douglasl330

    douglasl330 Senior Member
    Messages: 356

    Just like arc burn said clean and grease! When the plow is sitting, there are covers for the ones on the truck and you should be able to plug your cables together on the plow itself.The solo one should have a pocket that the cable slides into