1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

federal signal corner strobes

Discussion in 'Truck & Equipment Repair' started by Bobby Blaze, Feb 8, 2007.

  1. Bobby Blaze

    Bobby Blaze Member
    Messages: 92

    I have a set of 4 corner strobes set up on my 01 dodge,they are 5 years old and i have not had any problems with them until this year, they work only for about 5 minutes and then stop- the flash pattern is not what it used to be and when they stop working if i turn the switch off i have to wait a while to turn them back on. anyone have any idea what the problem could be, i was thinking that maybe i need a new power supply. any ideas ?
  2. mcwlandscaping

    mcwlandscaping 2000 Club Member
    Messages: 2,557

    did they get wet???? the heads i mean
  3. Rickco

    Rickco Member
    Messages: 89

    New power suply for sure

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    After 5 years w/no problems and now this I would check all my grounds real well and maybe even wire brush and reconnect them.

    Loss of a ground will over heat your box and when that happens they act just as you describe.

    I would make sure it did not get wet either like the poster before mentioned as well. My guess is a bad ground or 2.