1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

F250 Ford no lowbeams

Discussion in 'Ford Trucks' started by DSeeley, Feb 23, 2016.

  1. DSeeley

    DSeeley Junior Member
    Messages: 4

    Can anyone please help with my F250 Ford isolation module with no electrical juice, driver side went out first and now passenger side no juice on my truck or snowplow.
     
  2. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    what year?
    91 or older could be a bad dimmer switch or bad wire on the floor, 92 or newer could be a bad multi-function switch
     
  3. Randall Ave

    Randall Ave PlowSite.com Addict
    Messages: 1,984

    Welcome to the site! Now that that's done, we need lots more info, I take it its a Western. But fill in the blanks. Year, model plow, wiring style, picture of the, I'll stop there. :rolleyes:
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,971

    Randall.....that's to many details we don't need. Just give the poor guy the answer already....you know what it is, don't be mean this time
     
  5. cbservicesllc

    cbservicesllc PlowSite Fanatic
    Messages: 12,420

    Subscribing... I have an 08 F350 with no low beams... Boss plow, but no juice nonetheless... worked it all the way back to the multifunction switch and that's not the problem...
     
  6. Randall Ave

    Randall Ave PlowSite.com Addict
    Messages: 1,984

    No gold star for me today.
     
  7. DSeeley

    DSeeley Junior Member
    Messages: 4

    It's a 2002 Ford with a Fisher plow, what color is the wires that plug into the low beam on the low beam module, maybe there's a relay that's bad in the module, really don't wanna cut open the module if that's not the problem, wonder if they are replaceable.
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,971

    Modules are NOT serviceable.
     
  9. DSeeley

    DSeeley Junior Member
    Messages: 4

    Ok thanks guys.:)
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,971

  11. DSeeley

    DSeeley Junior Member
    Messages: 4

    Problem solved was a bad ground wire coming out of the harness, I simply runned a new wire on the truck side, and got all lights again.:)
     
  12. BUFF

    BUFF PlowSite Fanatic
    from FR NoCo
    Messages: 7,269

    A little off topic....... Your user name has the same last name and first initial of someone I know. Where are you located?