1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

ezv-not really sure whats wrong, any idea's?

Discussion in 'Fisher Engineering Discussion' started by plowman_25, Jan 15, 2010.

  1. plowman_25

    plowman_25 Member
    Messages: 71

    I have an 8.6 mm2 ezv. It seems to be acting up lately; I’m just not sure what’s wrong or where to start looking for a problem.

    The issues that I am having are:
    1- Under load it will not lift the plow. It’s not even that I’m trying to lift a lot of snow, but if it just has some stuck to the blade after I push it into the bank, it won’t lift it all the way up until I drop it and get what snow is on there to fall off.
    2- When I move the wings, or change modes, when it stops moving it does one more little jerk...maybe it’s normal, but being my first v I’m not sure.

    i just got a brand new controller so I’m thinking its not that, maybe the pump needs to be replaced? Or the s1 or cross over valves?

    Any advice would help me a lot!

    Thanks in advance guys
     
  2. LON

    LON Senior Member
    Messages: 749

    Pull the tank off and check for "slushing" on the filter.
    Pump pressure test if nothing found on filter.
     
  3. twgranger

    twgranger Senior Member
    from .
    Messages: 171

    Fluid full? My extreme v wouldnt lift worth a **** either entill i adjusted the lift pressure. Lifts like a champ now.
     
  4. plowman_25

    plowman_25 Member
    Messages: 71

    fluid is full....i am going to check the filter this afternoon and i'll try adusting the lift presure and see what happens then

    thanks
     
  5. 2kVRT

    2kVRT Junior Member
    from NY
    Messages: 1

    I'm having the same Exact problem.. plows identical ( 8'6 fisher mm2 ez v) flushed fluid, filters clean. Everything else works perfect, angle scoop, vee. Only when i lift the plow especially stacking banks, she wont lift for crap. Also jerks a couple seconds after plow is all the way in scoop.
     
  6. Shop's Lawn

    Shop's Lawn Senior Member
    Messages: 147

    I have a 9'6" that does the same thing. Anyone have a pic or can explain how to adjust lift pressure so maybe that will take care of it?
     
  7. risin187

    risin187 Member
    Messages: 57

    I think my problem is similiar, the plow wouldn't go up but everything else works
    It's at shop now I'll let you know what the solution is
     
  8. risin187

    risin187 Member
    Messages: 57

    update

    after the second time in the shop they replaced the main plug for the harness the 3 foot piece in the front the wire was fryed and dry rotted, funny they just installed the plow in nov but anyhow $75 for the part and $80 more for labor $106 first day $165 second day. i have since plowed 8 hrs with it no problem