1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ez-v mm2 light problem

Discussion in 'Fisher Engineering Discussion' started by Misterplow717, Jan 26, 2012.

  1. Misterplow717

    Misterplow717 Junior Member
    from Canada
    Messages: 10

    I have a ez-v mm2 with the 4port module on a 06 gmc sierra 2500 and having problems with the lights. The highbeams on the plow dont work, rightside signal does not work and the highbeam ends up flashing instead. Also the rightside light is dimmer than the driverside. When i disconnected the plow it basically did the same thing on the truck even though i took plow off.
     
  2. buddymanzpop

    buddymanzpop Senior Member
    Messages: 601

    Is this a new install or something you had working correctly and went bad? If new install what are the light harness part numbers?
     
  3. Misterplow717

    Misterplow717 Junior Member
    from Canada
    Messages: 10

    Its something I had workin then just went bad
     
  4. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    Make sure that all your harnesses are plugged into the isolation ALL the way and aren't loose.
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You have a poor ground. In the grill plug or plow side most likely. Time to get digging.