1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ez-V controler issue

Discussion in 'Fisher Engineering Discussion' started by RLM, Nov 20, 2014.

  1. RLM

    RLM PlowSite.com Addict
    Messages: 1,270

    I have a controler issue, I have swaped out controllers everything else works as it should. Controler doesn't even power up (light up). I tried cleaning internal contacts still same scenario. Where to start ? Should I just go buy a new circuit board & cord ?
     
  2. NHresident

    NHresident Senior Member
    Messages: 285

    if u have a 3 plug setup im not trying to be a wise guy BUT u need the plow hooked up if it isn't to have the controller pwr up if u have the 2 plug relay style it don't matter IF the plow is hooked up id start by chkng the red wire for keyed on pwr inside the cab on the control harness for starters
     
  3. RLM

    RLM PlowSite.com Addict
    Messages: 1,270

    Not trying sound like a smart a$&, truck is set up, works perfect (I have multiple trucks & plows, all set up same). When I switch to this controller I get nothing. That's how I have it isolated to a controller issue.
     
  4. NHresident

    NHresident Senior Member
    Messages: 285

  5. freeridemahony

    freeridemahony Junior Member
    from canada
    Messages: 2

    I have a similar problem to this no power on fish stick hook up red wire lights come on and no power mode also ground from harness to battery becomes live playing with it for 3 days now no luck
    Fisher minute mount v plow 3 wire 4 port module
    Also there are to fuses inside fish stick f1 f2 would check to see if there good before replacing
     
    Last edited: Nov 20, 2014
  6. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

  7. freeridemahony

    freeridemahony Junior Member
    from canada
    Messages: 2

    Bought v plow used been fighting with it for 3 days now with no luck
    been reading a lot of posts and manuals I just noticed that mine doesn't have any relays for the fire wall or no inline 10 amp fuse this may be why i'm having and ground Black yellow from controller harness direct to battery negative side going live every time I power up the red wire from main control harness . Im going to replace fuses tomorrow install new relays that are missing as ive done every other possible thing I have read and can think of with no luck . If that fails then its off to ordering all new harnesses controller and module that should eliminate any and all possibilities at a high expense. Any one have similar issues or thoughts on this problem advice would be grateful thanks