1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ez mount express meyers

Discussion in 'Truck & Equipment Repair' started by bh4691, Oct 19, 2015.

  1. bh4691

    bh4691 Junior Member
    Messages: 9

    Hi I'm looking for someone familiar with this system, mycontroler is blinking once(red wire, lift selenoid)it wont lifr the plow! I test the circuit inthe controler plug with the test light and it moves as it should! Im assuming a bad valve not allowing it to ground?! Any thoughts? Thanks gents/ladies
     
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,595

    Does plow go left when you press up? Have you checked for magnetism on the lift coil or B coil?
     
  3. bh4691

    bh4691 Junior Member
    Messages: 9

    everything moves correctly,except up. I tested it with a screw driver, no magnatism is present on that one, its weird. When i use the test light to test that circut for power with the test light. It works. Almost like its compleating the circuit.(ground
     
  4. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,595

    What pump is this? One wire mold into the coil or two wire with plug in connector? If it is single wire coil you can try cleaning under the small nut that holds the coil on but most likely the coil is junk. Two wire coils could be the connection, bad coil or broken wire in harness.
     
  5. bh4691

    bh4691 Junior Member
    Messages: 9


    I have the E68 pump two wire
     
  6. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,595

    You can try switching the coils out from the C coil to see if it is coil or wiring.
     
  7. bh4691

    bh4691 Junior Member
    Messages: 9

    Awesome!! Thanks!!