1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Exhaust

Discussion in 'ATV / UTV Snow Removal' started by UTAH, Feb 27, 2011.

  1. UTAH

    UTAH Member
    from Utah
    Messages: 32

    Yesterday morning when I was plowing snow with my '03 Sportsman 600 I chanced a glance down towards the exhaust and the first 6-8 inches were glowing bright red. Is that normal? Everything seems to normal: fan runs and has coolant.
     
  2. My07Brute

    My07Brute Senior Member
    Messages: 100

    No, its not normal, it means you are running lean. I also assume its hard to start when its cold out as well?

    My friends has a 04 600 and had to have a jet kit installed and his is bone stock.

    (Also make sure your air cleaner is clean, if its clogged you will run lean as well)
     
  3. UTAH

    UTAH Member
    from Utah
    Messages: 32

    Yep, real hard to start. That must be the problem.
     
  4. atv4wheeler

    atv4wheeler Junior Member
    Messages: 18

    All stock engines run lean due to emissions. Thank our government for that just like those POS unreliable tire pressure monitors that now come standard on all new cars. It is always in your best interest to tune your carb for optimum performance and engine health. Dynojet makes great kits for pretty much any model. BUT, you could also be running leaner than normal because of a dirty filer, air leak, etc...