1. Welcome to PlowSite. Notice a fresh look and new features? Explore this quick video tour of updates and enhancements. It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Error code 10

Discussion in 'SnowEx Products' started by SharpBlades, Mar 6, 2011.

  1. SharpBlades

    SharpBlades Senior Member
    Messages: 366

    I have a snowex 1075 that I bought last fall. It has been working good up until a couple weeks ago... now it throws an error code and doesn't work until I get out of the truck 2 or 3 times and manually move the spinner.

    I checked the manual and there is nothing about an error code "10" any ideas?
     
  2. clark lawn

    clark lawn PlowSite.com Addict
    from NE ohio
    Messages: 1,233

    it is not a "10" it is "OL" or overload. are you leaving salt in it? if the salt settles then you may have to spin it by hand. i try no toleave any in the hopper even if its just between jobs.
     
  3. SharpBlades

    SharpBlades Senior Member
    Messages: 366

    no... It's not an overload. For example if I try to start the spinner on speed 30 it tries to start, then it beeps and flashes 10. Today I was having to turn the spreader on, get out and like fling the spinner to jump start it. Could it be a bearing?
     
  4. racer47

    racer47 Senior Member
    Messages: 320

    did you buy it new ... sounds like moter is getting weak ... if your running bulk or wet salt they will give you troble if salt settles in bottom i got 1075 thats 3 winter old.... has had guts ran out of it but still looks new... still has red pin strip on it but it started doing that to me last snow.... i think im just going to replace moter... found 1 on ebay for 195.00 new... i have run 72 skids of rock salt throught itin 3 seasons with no trouble at a::drinkup:
     
  5. racer47

    racer47 Senior Member
    Messages: 320

    i took my 1075 apart moter looks like new so i took inspection cover off transmisson grease was real low and nasty i cleaned out grease sprayed degreaser and carb cleaner and blew out with air putt new grease in it putt back togeather it spins free now and feels like my 1 year old 575 i thought moter was going out but turns out trans grease low and dirty and needed replaced theirs nothing in them but pinion gears like rear end in truck it was a little worek but beat new moter or transmission so before buying anyparts take a look