1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Emergency Question....Pump? Problems

Discussion in 'Fisher Engineering Discussion' started by Bmxdkj, Jan 18, 2009.

  1. Bmxdkj

    Bmxdkj Member
    Messages: 57

    Hello, I have a 2 plug 7.5 straight blade plow. Tonight when hooking up I didn't have the push plates lined up perfectly to the plow itself and locked in one side of the plow. I plugged in the and jiggled the switch a bit and the other side locked in. Well I went to lift the plow and it lifted S L O W L Y about an inch, and that was it, the plow went dead. Dropped the plow down like it was supposed to and nothign else. The motor makes noise almost like theres no load on it. Any idea's what cold be wrong with this thing???!!! Any help is greatly appreciated.
  2. coldcoffee

    coldcoffee Senior Member
    Messages: 776

    It sounds like maybe your low on fluid or a frozen/clogged pump. What plow system are you running and when was the last time your fluid was flushed?
  3. snow7899

    snow7899 Senior Member
    Messages: 238

    Pull the reservoir off and check the pick up tube and the filter assembly. Replace the filter kit anyways while your in there and clean the magnet.
  4. Bmxdkj

    Bmxdkj Member
    Messages: 57

    Figured it out guys...thank you for your help. It was a frozen pump, put a torpedo heater on it for about 5 mins and it was fine. Fluid and filter were changed in November. Just been very very cold around here this past week.
  5. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Think its been cold everywhere!!!

    Change the fluid and flush the sytem otherwise it will freeze up again.