1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

eletric fan on a 07 ram hemi ?

Discussion in 'Ram Trucks' started by vmj, Jan 3, 2016.

  1. vmj

    vmj Senior Member
    from conn
    Messages: 752

    I have notice that when I hook up to my plow and truck is just sitting , that my fan turns on and stays on... after unhooking plow it turns off after a bit... Its a boss plow, is it normal or something in the eltrical of boss..?
    Thanks..
     
  2. ggb6259

    ggb6259 Senior Member
    from SW MI
    Messages: 214

    Not hemi savvy and y said an Electric Fan?

    My 04 (4.7) has a mechnical fan off the front of the block. I found my fan clutch was not working correctly and put a HD Fan Clutch on. The Heavy runs about 30-% more rpms. Just throwing this out there in case you actually have the mechanical fan...
     
  3. vmj

    vmj Senior Member
    from conn
    Messages: 752

    mmmm ill have to look at it better tomorrow....
     
  4. Ramitt

    Ramitt Senior Member
    Messages: 156

    Im not sure about an 07 but I know on the newer cummins trucks they have a snow plow setting that keeps the truck cooler. Who set up the truck with the plow? maybe they added a work around to keep the truck happier.. I wouldnt worry about it tho if anything be happy lol
     
  5. vmj

    vmj Senior Member
    from conn
    Messages: 752

    lol it was set up at a boss dealer.. I just purchased the truck last year and I noticed it. the tem does not rise. just seamed odd the way it turns on..
     
  6. vmj

    vmj Senior Member
    from conn
    Messages: 752

    guess this is normal........
     
  7. Ramitt

    Ramitt Senior Member
    Messages: 156

    Try calling the boss dealer and ask if they every heard about a truck doing it.
     
  8. vmj

    vmj Senior Member
    from conn
    Messages: 752

    good point im assuming that its only my truck... lol thanks
     
  9. vmj

    vmj Senior Member
    from conn
    Messages: 752

    called plow dealer today.... They said it must be a ground issue or circuit issue that's starting fan when harness is pluged in.......