1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Electrical Problems and it's snowing!

Discussion in 'Truck & Equipment Repair' started by Mark13, Feb 9, 2010.

  1. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,719

    Went to leave for class to find my truck has no parking lights, running lights, dash lights, or high beams on the plow (turn the plow high beams on and they switch to the truck). The low beams on the plow work, truck radio works, and plow works as normal.

    If I unplug the plow and replace the 20A fuse everything works, hook the plow up and it blows the fuse immediately. So I'm guessing I have a direct short somewhere. Is there anywhere on the unimounts that commonly have issues? I checked the truck side wiring, pulled the grill off, and pulled the plow head lights apart, sprayed electrical cleaner in the grill plugs and plow plugs and am letting them dry. I saw nothing that should give me trouble. Also checked the relays and didn't notice anything abnormal, cleaned a couple of the terminals and that was it.


    (Everything worked at noon today when I ran my route)
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Pull the plow lamp housings apart and check for a shorted marker wire in the bulb sockets. Common spot on the old style lamps.
  3. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    I'm not familiar with the Western's Mark, but did you double check your grill connectors? Ice/water? Also, pull the park/turn bulbs on the plow out and try it.
  4. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,719

    Will do. I pulled them apart and checked for water and corrosion but didn't look real close at the marker lamp wires where they go into the sockets. I hope that's my problem.
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Reference note: same exact pump and electricals as a SEHP equipped MM1.
  6. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,719

    Broken bulb connector on the drivers side bottom turn signal/marker light on the plow.
  7. hydro_37

    hydro_37 PlowSite Veteran
    from iowa
    Messages: 3,790

    glad you got it fixed.