1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

electrical headache

Discussion in 'Hiniker' started by loyboy, Dec 28, 2008.

  1. loyboy

    loyboy Member
    from KCMO
    Messages: 86

    I have a 2005 8.5 v plow. It was working fine when I parked it Friday. went to get in 6 hours later and no power to controller. so i start troubleshooting. I cannot get power to go through my axillary relay which I think powers the controller. It's by the 2 headlight relays.

    when i hard wired (bypassed) the relay with solid copper wire i get everything to work just fine but i don't want to keep it that way cause it's not right. I sure all my grounds are good. Any help would be appreciated.

    Thanks, Kenny
     
  2. NICHOLS LANDSCA

    NICHOLS LANDSCA PlowSite Veteran
    Messages: 4,302

    If you bypassed the relay and it works, I think you already found the problem.
     
  3. loyboy

    loyboy Member
    from KCMO
    Messages: 86

    i'm sorry i forgot to add i put all 3 new relays in and it still wouldn't work until i bypassed the first relay
     
  4. topdj

    topdj Senior Member
    Messages: 396

    Last edited: Dec 28, 2008
  5. alaska blue ox

    alaska blue ox Junior Member
    from Alaska
    Messages: 23

    check to see if you are getting power and ground to the control side of the relay. if bypassing it works and you tried a new relay then your problem is most likely in the power supply controlling that relay.