1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

elect issue...sparks and smoke=not good

Discussion in 'Truck & Equipment Repair' started by trucker33, Nov 16, 2009.

  1. trucker33

    trucker33 Junior Member
    from Kansas
    Messages: 1

    I have a 04 F350 that I have been running a meyer setup on.

    I took it out this season and when connecting the large power lines it sparked bad and the ground wire got hot and started to melt. I immediately disconnected and don't know what to do..the plow controller is off and the switch is off also. still sparks and gets hot when its all on too.

    I have had extensive work done to the engine and they actually pulled the cab recently to do head gaskets. Would I possibly have a bad grounding issue?
     
  2. WeDoSnowplowing

    WeDoSnowplowing Senior Member
    Messages: 160

    Sounds like they mess up on the wires / power cables. By connecting a power to a ground. Or something else. Without seeing a pictures of the wiring hard to say. When I had my engine replaced The hook up all grounds to the head Black from battery. Black one from plow power unitl. If Pos & Neg are black They may have put a Pos to a ground.
     
    Last edited: Nov 16, 2009
  3. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    definatley sounds like they hooked somehting up wrong when the put the cab back on, need to get the schematics from meyers site and check it out.