1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Edge 9000 problems

Discussion in 'Strobe Lighting' started by elardner, Aug 20, 2010.

  1. elardner

    elardner Junior Member
    Messages: 3

    I have my old edge 9000 up and running on my truck, but I am having problems with the corner strobes not working. The smaller strobes work just fine, but the corner strobes only work half of the time, and usually it is just the rear ones working. Although occasionally both front and back work. Any ideas?
     
  2. smokejmpr

    smokejmpr Inactive
    Messages: 159

    open the lightbar up and switch the wires that goto the power supply. if the problem fallows than the power supply is bad. you will need the numbers off of it.

    let me know if you need any more help.
     
  3. elardner

    elardner Junior Member
    Messages: 3

    Yeah, I switched them and now the outer lights work and the inner no longer do. I believe I have the 2ZFO power supply, but I don't have much idea what that means as I am new to this game.
     
  4. smokejmpr

    smokejmpr Inactive
    Messages: 159

    With that info it is your power supply. if you get all the #s of it I can get you a price on what it will run.
     
  5. elardner

    elardner Junior Member
    Messages: 3

    There are two numbers on the metal case of the supply, those are 2ZFO13Q14015-4BB and 01-0267690-00C. I am not sure what either of those numbers designate.
     
  6. smokejmpr

    smokejmpr Inactive
    Messages: 159

    that is what i need give me a couple of mins and i will have a price for you.