1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60h slow??

Discussion in 'Meyer / Diamond Products Discussion' started by ed39, Jan 22, 2012.

  1. ed39

    ed39 Senior Member
    Messages: 120

    I did a serivce to the pump this year changed most of the fluid and cleaned the little filter in the bottom of the unit. I used the CAP autopsrts generic all weather plow fluid which is from what I read good for cold weather the newer stuff.. I also installed a brand new electric motor. The plow is dog slow and seems like its straining until it warms up. After about 15 min of use the plow is lighting fast. Should I get a flush kit and put all new Meyers fluid in it or? Do I have a bigger problem?
     
  2. Boomer123

    Boomer123 Senior Member
    Messages: 340

    I only use Meyers fluid with never any problems. I would flush and start over.
     
  3. jjklongisland

    jjklongisland Senior Member
    Messages: 470

    I added a second battery in my truck... worked alot faster...
     
  4. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,681

    Did you clean both filters? And completely flush the system and put meyer fluid in.
     
  5. Fourtrax250R

    Fourtrax250R Senior Member
    Messages: 109

    I've never heard of that fluid, that being said I only use Meyer m1 with no problems.
     
  6. ed39

    ed39 Senior Member
    Messages: 120

    It's at your local auto parts store or at least mine. It's supposed to mix with everything and be suitable for the cold weather. I found that strange I have serviced a few Meyers and there is two filters behind those bolts in the lower unit. I only found one.... I have one battery with an 140 amp alternator. Like I said it gets better as I use it more or "warm it up" so to speak. Depending how this winter goes in new England I might order that flush kit from central parts
     
  7. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,681

    E60 has one in filter in front and one in back.
     
  8. NickT

    NickT Senior Member
    Messages: 707

    Gotta be the fluid bud,you need to flush the angle rams and pump, I use the SAM blue fluid and have never had freeze ups