1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 won't go right

Discussion in 'Meyer / Diamond Products Discussion' started by tinffx, Feb 3, 2010.

  1. tinffx

    tinffx Member
    Messages: 68

    Ok, well it intermittently won't go right. The pump and fluid are clean, and I replaced the C valve & coil with Meyers parts. I'm thinking I might have a broken wire, but I can't make it not work when I put a test light on it. Its quite annoying but it doesn't really cause a lot of problems. Thanks!
  2. IApushn

    IApushn Junior Member
    Messages: 25

  3. IApushn

    IApushn Junior Member
    Messages: 25

    I read your post again and it sounds like it will work in the shop correctly but not when you are working. It could just be a connection loose or like you said, a broken wire. You could try to check all of your connections and plugs and if it still won't work maybe try a jumper all the way from the switch to the motor. I'm just throwing things out there. I haven't had that problem. Maybe someone else knows a better way.
  4. golfmanres

    golfmanres Senior Member
    Messages: 150

    I have this problem every so often. I just shake the plow up and down and it fixes it most of the time. Some times i have to run into something (curb) and it will fix it. I noticed the right ram was extended all the way out and possible too far. I was also told that one of the Coils (cant remember which one) that the valve was sticking that I would have to replace it. I read the meyers tech manual and it pretty much points it to the coil

    My 2 cents