1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 That Would NOT Drop!

Discussion in 'Meyer / Diamond Products Discussion' started by BBChevy, Jan 16, 2008.

  1. BBChevy

    BBChevy Junior Member
    Messages: 21

    A few Weeks back?I had posted a Problewm that i had with my Fairly New E60 Meyers Pump.I cant Find the Old Thread.........????But,anyway i Told B&B that i would let him and Others know when i did get It Figured out?
    After a Total Disasemble,i found the Drop port had a peice of O-Ring and some other debree in the port?Cleaned and Blew it out good and SHAZZZZAM,it Drop like a Hot TURD Now!But,i will tell you Guys with Drop Problems when you adjust that set Screw it IS TOUCHCY,a Little bit goes a Long Way!When i 1st put it back together it would Drop so Fast that it was SCARY!
    Greg :cool:
  2. f250man

    f250man PlowSite Veteran
    Messages: 3,124

    Glad you found the problem. Mine was doing the same thing last year but it was ice in mine.
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Good to hear it's fixed Greg....and you'd be surprised what a little chunk of O-ring can foul up. :realmad:

    Heres your original thread you were lookin for if you want to re-read it....http://www.plowsite.com/showthread.php?t=54883