1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

e60 pump problems

Discussion in 'Meyer / Diamond Products Discussion' started by grabngearz, Jul 20, 2011.

  1. grabngearz

    grabngearz Junior Member
    Messages: 4

    Hi guys , first time post, and first time plow owner. Last spring I bought a 8' meyers poly plow with a e60 pump with a slick stik for $1200.00 . This is going on a 99 suburban 2500 for my own drive way use, drive way is about 500 ' long. After installing the blade on the vehicle I had little issues with the pump like A coil and valve, and blade would go side to side then lock up , therefore having pressure on both hoses,I replaced the quick couplers on the hoses and it seems to have fixed that problem. Now my issue is when I turn the blade to the left and let go of the slik stick the blade comes to a gradual stop, like I think it should. When I turn the blade to the right and let go of the controller the blade stops instantly and jerks back and forth . is this normal? I'm scared this will break somthing. I would think I should come to a gradual stop like the left side.
    any help would be greatly appreciated. Thumbs Up
    thanks mike
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Welcome to Plowsite:waving:

    You have the membrane (touchpad) controls? It is possibly a controller issue, if you have a buddy that would let you plug his control in it would answer that question. Otherwise it could be a coupler issue, but since you just replaced them all we will assume (there is such thing as new failed out of the box) they are all good.

    The controller has the "cushion" as part of it's programming, if you have the Slic Sick or old duel controls the slam to a stop would be the norm.
     
  3. grabngearz

    grabngearz Junior Member
    Messages: 4

    slik stik are the controls, so you are saying only to the right the slamming is the normal? left is a nice slow stop
    thanks mike
     
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    The unit defaults to the left so there is no valve closing and the pump just spins down. The slamming when angling right is caused by the valve suddenly losing voltage, the membrane unit is designed to gradually decrease the power so the valve closes slowly.
     
  5. grabngearz

    grabngearz Junior Member
    Messages: 4

    how do I fix this prolbem?
    thanks mike
     
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Change over to the membrane. It really is only a problem if it bothers you it will not harm anything.
     
  7. grabngearz

    grabngearz Junior Member
    Messages: 4

    thanks for your help Basher, I think ill just leave it the way it is.
    mike
     
  8. Dubl0Vert

    Dubl0Vert Senior Member
    Messages: 178

    Wow! glad i read this. I tried another keypad and it turns out mine is bad :realmad:

    Anyone know how long it will keep working?