1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 pump problem

Discussion in 'Meyer / Diamond Products Discussion' started by kandklandscape0, Dec 11, 2007.

  1. kandklandscape0

    kandklandscape0 Senior Member
    Messages: 113

    when angling left right and raising the plow the controller lightning bolt will light up.

    we have the hand held controller

    reset the controller works fine until it happens again, re set and works good, so on n so on

    we checked all the magnetisizum and wiring is fine, all tightended up we put elec connector grease on all wire ends and went over eveything... any ideas?

    plow is approx 2 years old
     
  2. roblandscape

    roblandscape Senior Member
    from Phila
    Messages: 187

    It has to be a wiring issue, sounds to me like a bad ground, check your solenoid to make sure all conections are tight as well as all of the other wiring. I know you said you did this but I think it is worth another shot.
     
  3. Kenyou

    Kenyou Senior Member
    Messages: 375

    If this is a ground problem, make sure that you don't just tighten and grease them. Take them apart and make sure you have nice shiny and clean metal and then put dialectic grease on all the surfaces and then tighten them down.
     
  4. kandklandscape0

    kandklandscape0 Senior Member
    Messages: 113

    did it again played with it for 1/2 hour and it works 100% now, so just needed re cleaned and lubed