1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 pulling too many amps?

Discussion in 'Meyer / Diamond Products Discussion' started by jjfinn, Nov 16, 2008.

  1. jjfinn

    jjfinn Member
    Messages: 56

    I am new to the whole plowing with your own truck always had a company one that I never had to worry about doing the fixes myself, Just got a Meyer c-8 on my Dodge Ram and when I had it hooked up the people told me that the motor was pulling to many amps. What does that mean? New motor or Pump? Any help is greatly appreciated as we have a lake effect watch for tomorrow night which is going to dump 6 to 8 inches.
  2. tom_mccauley

    tom_mccauley Senior Member
    Messages: 465

    could be either one:drinkup: also check ALL grounds a bad ground will cause it to draw a bunch!!!!!!
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    I assume they actually tested the motor for excessive amp draw? Are the functions slow? Has the pump been serviced lately?

    If your cable connections are 100% then likely it's the motor itself causing the hi amp draw...especially if it's an older unit or a single stud motor with no dedicated ground stud. They like to rust/corrode internally as well as where the motor mounts on the pump housing.

    A plugged filter is the only other normal cause, has it been serviced lately? If not you'll definitely want to consider doing it.