1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

e60 motor

Discussion in 'Meyer / Diamond Products Discussion' started by countryboy1365, Dec 24, 2010.

  1. countryboy1365

    countryboy1365 Member
    Messages: 93

    I have an e60 problem. The e46 spare pump works as it should when connected, however If i swap out the e60 the selonoid clicks, all the coils have power but the motor wont run. I took a set of jumper cables and hit the motor will 12v and still nothing would it be safe to say my motor is bad or am i missing something.
     
  2. Bashby

    Bashby Senior Member
    Messages: 228

    Either bad motor or bad ground, sometimes they corrode where the motor bolts to the pump. To check it ground the motor housing to bat- with a jumper cable
     
  3. Nasty-Z

    Nasty-Z Senior Member
    Messages: 370

    Single stud or two stud motor on the E60?

    If it is a two stud motor and would not run with the jumper cables attached to the two studs it's motor time.

    If it is a single stud motor , like Bashby said , check the endplate of the motor for corrosion and a possible bad ground issue , common with the single stud motors.

    TOM
     
  4. countryboy1365

    countryboy1365 Member
    Messages: 93

    Its a two stud. I should have mentioned that. Are the aftermarket moters ok or should i drop the 260 on a " genuine Meyer"
     
  5. Nasty-Z

    Nasty-Z Senior Member
    Messages: 370

    Where in PA are you ? I may have something.........:rolleyes:

    I know people (inclding myself) who have used aftermarket and had no problems , othere swear at them ...... Up to you I guess.

    The price on OEM Meyer has gone through the roof.......

    TOM
     
  6. countryboy1365

    countryboy1365 Member
    Messages: 93

    I'm just outside of quakertown
     
  7. Nasty-Z

    Nasty-Z Senior Member
    Messages: 370

    You are about 45 minutes from me, I am 10 miles north on Rt 209 off of the Mahoning Valley exit of the N/E extention of the turnpike (Exit 74)

    I know I have a couple used OEM Meyer motors off of units I dissassembled , if it's something you would be interested in shoot me an email , tomsnastyz@yahoo.com

    TOM
     
  8. countryboy1365

    countryboy1365 Member
    Messages: 93

    Email sent