1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 meyers problem

Discussion in 'Meyer / Diamond Products Discussion' started by cec3dale, Mar 1, 2009.

  1. cec3dale

    cec3dale Junior Member
    from PA
    Messages: 3

    When I touch the key pad to try to put up the plow I keep hearing a clicking noise out by the solenoid. Replaced it and still hear the clicking and nothing works is there a fuse that I should be looking for or is it a module that is out??? I NEED HELP....BOB
     
  2. Snowplow71

    Snowplow71 Senior Member
    Messages: 284

    When I had my POS meyer, I actually had 2 NEW solenoids BAD from Napa.
     
  3. cec3dale

    cec3dale Junior Member
    from PA
    Messages: 3

    We just had to replace both batteries because they went out....of course they were 7 years old. Now everything worked up until we put the new batteries in yesterday. However we did not do the electrical system for the lights. We just put a new soleniod on it this afternoon and still clicks....should we check the motor next???? Bob
     
  4. cec3dale

    cec3dale Junior Member
    from PA
    Messages: 3

    Okay found the problem the ground wire on the motor was loose....as soon as we tighten it it worked.....Thank you for the help....Bob
     
    Last edited: Mar 1, 2009