1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 lift problem

Discussion in 'Meyer / Diamond Products Discussion' started by jb4020, Jan 20, 2014.

  1. jb4020

    jb4020 Junior Member
    from SE PA
    Messages: 5

    I have a E60 that goes up without the plow fine but with the weight of the plow it will only go up if I I bump the up switch. If I just hold the up switch it will raise a few inches and then it sounds like it's hitting a relief. If I adjust the drop speed it will raise but very slow. I replaced the A coil and valve, both filters , and set the pump pressure with a gauge to 2500 psi. Any ideas? Thanks
     
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,604

    Check B valve o rings. Also lift tube base o ring could be damaged or bad packing cup.
     
  3. Dubl0Vert

    Dubl0Vert Senior Member
    Messages: 178

    Does it sweep left to right correctly?
     
  4. JeepCoMJ

    JeepCoMJ Senior Member
    Messages: 284

    Number one question. Do you have a meyer blade, and how big is it?


    I had a customer buy an e60 from me and he was running a 10', 925lb blade. Would not lift at stock psi no matter what we did. Had to bump him up to 2500 with the large diameter cylinder and piston installed,
     
  5. jb4020

    jb4020 Junior Member
    from SE PA
    Messages: 5

    The blade is an 8 foot Meyers model C-8. It worked fine until recently.
     
  6. JeepCoMJ

    JeepCoMJ Senior Member
    Messages: 284

    Packing is bad, Lift cylinder is pitted, cylinder base seal is bad, or pump is bad internally.

    Sounds like it could use a rebuild. Or at least a basic seal kit and a good cleaning.
     
  7. jb4020

    jb4020 Junior Member
    from SE PA
    Messages: 5

    Should the plow leak down if the packing is bad on the lift cylinder?
     
  8. JeepCoMJ

    JeepCoMJ Senior Member
    Messages: 284

    It can. But it also can bypass.



    Hey, unplug the a coil (black wire), and c coil (green wire), and give it a shot going up.


    It's possible that the ground failed on your controller and that the controller is now putting out positive for all coil wires. If it goes up just fine, clean grounds in harness, try again. If no luck, check wires for grounds. Still no dice, new controller is necessary.
     
  9. jb4020

    jb4020 Junior Member
    from SE PA
    Messages: 5

    I tried unplugging the green and black solenoids and it lifted fine. I ended up getting a new controller and it works great now. Much thanks!