1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 jumping while raising

Discussion in 'Meyer / Diamond Products Discussion' started by Ramitt, Jan 12, 2016.

  1. Ramitt

    Ramitt Senior Member
    Messages: 156

    Got our meyer hooked up today since we were expecting snow.. Did work on the plow in the fall got it all fixed up and fluid changed and worked fine.. Sat in the garage till today.. Hooked it up and when lifting, it like surges.. Not like a power surge just the plow is jumpy.. 1st thought was low on fluid.. Which it was so I put some in it and still does it.. Angles left and right fine.. So ran it through a few cycles and check gauges light came on in the truck so thought ok must be a power issue since the truck has never did that(figured dirty connections pulling too much power) Cleaned all the connections up and still does it... Not sure what to check next? Dirty filter? Pump going? I thought those issues would cause the angling to do the same but it doesnt so thats why im lost... All the guys were busy with the snow today so I had no choice but to use the truck to plow.. Plowed for about 3 hours with it and never quit doing it..
     
  2. BUFF

    BUFF PlowSite Fanatic
    from FR NoCo
    Messages: 7,263

  3. Ramitt

    Ramitt Senior Member
    Messages: 156

    Solenoid is new.. No filters weren't cleaned.. Prob should of.. Never done it on a e60 does the valve block have to come apart or can you do it with it still in?

    The pump isnt the high lift.. Still a single pole motor.. Has the 2 angle connections side by side on top of the valve block...


    Looks like this
    [​IMG]