1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E60 issue Help please

Discussion in 'Meyer / Diamond Products Discussion' started by joe47348, Feb 4, 2011.

  1. joe47348

    joe47348 Junior Member
    Messages: 3

    i have a E60 pump. was just doing a drive way here in indiana and all of the sudden my plow wouldnt lift anymore and would only turn left and right if you helped it. i have a 7.5 meyer plow. im not sure what each valve does? my c valve coil the green wire broke so i screwed a screw into it and wrapped wire around screw to get me by before this happened. now im lost and not sure what to do? any suggestions i would really apprieciate it. all the valves were new at begining of season and the pump rebuilt also. at first it would go up but go down almost imediatlly. guessing i need to replace c valve coil that the wire broke.? not sure. help please and thank you.
     
  2. LawnzzzANDsnow

    LawnzzzANDsnow Junior Member
    Messages: 19

    meyer .com will tell you how to check your pump and coils.
     
  3. joe47348

    joe47348 Junior Member
    Messages: 3

    im almost begging...

    replaced the c coil still will not lift but will angle left and right. and will lift without the plow attached.....please any help? plus i have magnatism on all coils ...down my a coil....up my b coil.. and right my c coil. but no magnatism when left is pushed? am i supposed to have magnatism when left is pushed on touch pad?
     
  4. Bashby

    Bashby Senior Member
    Messages: 228

    Is the motor running? Full of fluid?
     
  5. supercuts

    supercuts Senior Member
    Messages: 114

    replace the valve under the red wire coil. mine just did this monday. look up meyer troubleshooting there is a whole chart.
     
  6. joe47348

    joe47348 Junior Member
    Messages: 3

    Yes pump is running. and fluid level is inch and half below fill hole like i was told. i will replace the valve as soon as i can. Any other pointers?