1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E58 new shaft broken?

Discussion in 'Meyer / Diamond Products Discussion' started by brianbora1, Oct 8, 2014.

  1. brianbora1

    brianbora1 Member
    Messages: 68

    Noticed that my new shaft is broke at the tapered part at the base before the threads. Any idea how this could happened? I am using the classic mount. Shaft isn't even a season old. Thanks for any help!
     
    Last edited: Oct 8, 2014
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,946

    Ok I'll bite, what are you talking about?
     
  3. brianbora1

    brianbora1 Member
    Messages: 68

    Pump shaft where the brass washers and rubber washer go, it is broke right where it goes from the shaft to the tapered bolt. Clean break. If I could figure out how to add a picture I would! Lol
     
  4. brianbora1

    brianbora1 Member
    Messages: 68

    or it's called the Lift Ram..8" if that helps
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,946

    So the lift ram broke. Was it broken inside the housing or outside by the lift arm?
     
  6. brianbora1

    brianbora1 Member
    Messages: 68

    Inside at the base.
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,946

    Might be better with pics. Could be weak metal, could be something bent, could be bottoming out
     
  8. racer47

    racer47 Senior Member
    Messages: 324

    sent you a pm give me a call might have your answer