1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E4OD Tranny

Discussion in 'Ford Trucks' started by redplowman, Jan 18, 2011.

  1. redplowman

    redplowman Member
    Messages: 61

    Good Morning Everyone,

    Got a question for you all this morning. Just wondering if a E4OD Transmission out of a 91 Bronco will work in a 92 F-250 4x4? I know they are both E4OD but not sure about the shafts and gearing. I would greatly appreciate any response. Thanks

    Redplowman
     
  2. linckeil

    linckeil PlowSite.com Addict
    from CT
    Messages: 1,265

    i believe they all are the same, but i'm not 100% sure on that. i do know that the 95.96, and 97 e4od's are the strongest ones from the factory. the early 90's units are much weaker.
     
  3. Dustball

    Dustball Senior Member
    Messages: 274

    What engine is in the F-250? If the F-250 has a 300, 302 or 351- you're good to go.
     
  4. redplowman

    redplowman Member
    Messages: 61

    5.8 in both
     
  5. greentexasblock

    greentexasblock Junior Member
    from texas
    Messages: 9

    Hi my name is Alex I have a ford f-350 is showing me the same flashing light but if I try to go on drive or 1st & 2nd gear it will stall or will hessitate to go ,,,but if I go really slow trying no to force the transmision.. it will eventualy go, once I pass the first gear it will eventually run perfectly but again when ever I get to a stop, it is the same story all over again. this is allso in reverse .In neutral and park motor will work perfect. When the light starts blinking and the motor acting up I turn off the truck and restart it back on and will work normal and will run great but out of nothing the light starts blinking if Im in a stop or up hill and the ..just for the records a mechanic replaced the( I do not know the correct name for it but I remember it was somthing like) transmission valve box or something like thatas well as the new oil & filter .. will to end the story fast it did work for a good 6 to 8 monts but here I with the same situation again.. thanks!