1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47H No Up & Low Voltage to Red Coil.

Discussion in 'Meyer / Diamond Products Discussion' started by Bens95cobra8594, Nov 30, 2007.

  1. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Hey everyone... first post...good for me.

    I have a Meyers e47H that seems to have annual problems (have to love that).

    Anyway... this year it won't go up, it just angles left instead.

    There is power going to the motor, all the connections (and ground) seem okay.
    There is very low voltage (less than 1 volt) going to the Red coil (B I think).
    There is very low voltage coming out of the red wire from the single joystick.

    I have a Meyers trouble manual for that pump motor, but have exhausted the diagram. I really don't want to replace the wiring harness because the trouble tree said that is the problem. I have trouble believing that a wiring harness will just stop working after 13 years of service. Possible, but I am skeptical.

    So question is this: What is the problem? What else can I look for or trace down?

    I really don't want to dump a ton of $$ into the thing taking it to a local dealer, but am not opposed to buying parts and installing them.

    Thanks!!
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Will it angle to the right?
     
  3. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Nope...no right action.
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If all it will do is angle left... then more than likely you have a control or wiring problem. Angle left is the default function when NO valves are energized..

    Did you check to see if you have full battery voltage going to the control switch and coming out at the switch?
     
  5. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    No.... but I guess I will be doing that tomorrow, seeing as it is snowing tonight. HA HA.

    Thanks, will check and see.
     
  6. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Controls were junk. just like you guys said.

    The slick stick & connector has been petering out for a few years, but this year it took its final dump.

    Ordered new stuff from Angelos, should be here this week (hopefully).

    Thanks guys!
     
  7. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Guys -

    Just threw in the controls today, plow works cherry again. Spewed a little fluid b/c it was overfilled, but ready to rock out with my c*ck out now.

    Thanks for the help.