1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47 problems (the squirter)

Discussion in 'Meyer / Diamond Products Discussion' started by farmermatt, Dec 21, 2005.

  1. farmermatt

    farmermatt Junior Member
    Messages: 11

    i am trying to get this thing working and i seem to have perfect up and down function but any time the pump is on it squirts fluid out beetween the valve body and the main housing it dose this no matter what function is selected i replaced the o-rings in the three holes that mate to the block so to make a long story short i am lost and need the help before it snows :)
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Are you sure you have the right o-rings, thickness as well as dia.? have you put a straight edge to the Angle block and base to make sure they are not warped?
     
  3. bnewell

    bnewell Banned
    from Ohio
    Messages: 91

    did the problem just start?? Where did you get the replacement o-rings?? Any chance there is a crack in either the PA block or base??

    Brian
     
  4. lawnmedic

    lawnmedic Senior Member
    Messages: 703

    Inspect the cavities on the base when the angle block is removed. I had a hole blown out of an old e-47 when a driver drove over some rough railroad tracks at high speed...
     
  5. lohr

    lohr Junior Member
    from 18411
    Messages: 21

    When you seperate the pa blogk from the sump base look near the filter /strainer castings ,I have on more than one ocassion I have found hair line cracks that will just keep leaking.Good luck
     
  6. farmermatt

    farmermatt Junior Member
    Messages: 11

    thanks

    I found a crack in the base and bought me a new one that stopped it