1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47 Problem

Discussion in 'Meyer / Diamond Products Discussion' started by DAZ982500, Feb 10, 2006.

  1. DAZ982500

    DAZ982500 Senior Member
    Messages: 142

    This is the second time that this has happened.It has been in the teens around here, overnight.The blade angles and raises but is real slow lowering.This is what I've done.Fluid flushed 2 weeks ago.Filters cleaned out.All connections are good.Have not checked solenoid, I thought about some antifreeze but was advized against this.Any ideas please.Dave
     
  2. Big Nate's Plowing

    Big Nate's Plowing PlowSite.com Addict
    Messages: 1,266

    what tye of fluid are you using?
     
  3. Hammer

    Hammer Junior Member
    Messages: 26

    Another cause that prevents the blade from dropping at it's normal rate is the plastic sleeve under the cover assembly. Meyer# 15199 I've seen rams that won't lower at all because of this sleeve.
     
  4. Jay brown

    Jay brown PlowSite.com Addict
    Messages: 1,783

    does it have a lowering set screw like an e 60?
     
  5. bnewell

    bnewell Banned
    from Ohio
    Messages: 91

    E-47's do not have the adjustment for the plow drop speed.

    When you flushed the system, did you also change the fluid in the reversing cylinders??

    I would take out the "A" valve and clean it.

    Brian
     
  6. DAZ982500

    DAZ982500 Senior Member
    Messages: 142

    bnewell how do you clean out "A" valve.Dave
     
  7. Big Nate's Plowing

    Big Nate's Plowing PlowSite.com Addict
    Messages: 1,266

    take the coil off and pull the valve, then give it a ****** with some carb cleaner, or just replace it, the cartridge is less then $50
     
  8. DAZ982500

    DAZ982500 Senior Member
    Messages: 142

    Thanks Big Nate will do this tomorrow.Dave
     
  9. Big Nate's Plowing

    Big Nate's Plowing PlowSite.com Addict
    Messages: 1,266

    [​IMG]

    be sure to get the screens real good
     
  10. mike33

    mike33 Senior Member
    Messages: 335

    Snow Plower

    Used meyer for 8 years always problems, sell it and buy Boss. Or you can do what i did when using meyer products, carry all the extra valves and coils. Have a back up harness like a nascar, and if you cant fix it in 20 minutes carry a spare pump with you. This is the bull --------- i went thru for 8 years.years. Buy red and make money plowing instead of working the plow. Also that fluid that is supposed to be good to -20 it freezes to!
     
  11. Big Nate's Plowing

    Big Nate's Plowing PlowSite.com Addict
    Messages: 1,266

    I fought with meyers for 5 years and then said to helll with it and bought a snoway, however it isnt the fluid that freezes it is water in the system that does
     
  12. mike33

    mike33 Senior Member
    Messages: 335

    Bobcat snowplower

    Nate ,
    Glad to see some one else got wise. I thought the fluid was freezing, or due you thinh when the ram goes down it takes water with it?

    MIke
     
  13. mike33

    mike33 Senior Member
    Messages: 335

    Bobcatsnowplower

    Thats no bull either about having extra parts and spare pump behind the seat.
    I still have to do this for my sub guys if they brake im the one who looses.I think one of the problems Meyer sat on there asses all them years and did nothing to improve there product and the red ones came along and kicked there but.Look at a E-60 now and look at one 12 years ago , pretty well the same. And for an item i foot in height and 1.5 wide there is to much mechanical and electic happening.
     
  14. DAZ982500

    DAZ982500 Senior Member
    Messages: 142

    I cleaned everything out works ok today, however, its warmer too.My fear is that, as indicated there may be water trapped in the system somewhere that I can't get at.I don't feel like changing fluid every week.I think the best way to solve this is to purchase new equipment.This year has not been a banner year, infact it has been a terriable year.Any recommendations on where to go from here.1. purchase whole new set up 4K(WESTERN, BOSS HINIKER) 2. New pump with current blade.3.Keep working with this problem.Number 3 is in this position because its the most risky option but cheapest.I typically want dependable equipment.....I HOPE NEXT YEAR IS BETTER.Dave
     
  15. fernalddude

    fernalddude PlowSite.com Addict
    Messages: 1,105

    if it works why fix it

    I have been running meyers for over 25 years and most problems are from lack of maintance the problem is the valve nate knows just replace it .The needle valve in the stem is sticking if the stem is bent or damaged at all the valve wont move easy when the solioned is energized.Have you been tapping on it with a hammer or anything else that's the first thing people do. that deforms the shaft and makes it hard for the valve to open.
     
  16. DAZ982500

    DAZ982500 Senior Member
    Messages: 142

    Thanks for the come back.I have not been tapping anything I have maintained this equipment to the best of my knowledge base.I am always willing to learn more.My main concern is fixing problem then making sure that overall the equipment is in good shape which is what I thought it was at the beginning of the season.Everyyear plow gets fluid flushed and refilled.Everything gets looked over and fixed if I see a problem.This the best I can do.Dave
     
  17. fernalddude

    fernalddude PlowSite.com Addict
    Messages: 1,105

    ok dave if it works good in 50+ deg it might not work when its below frezing so check the valve its a simple fix
     
  18. mike33

    mike33 Senior Member
    Messages: 335

    Bobcat service

    I did mainatin my meyer plows, checked out after every storm and would still go out and brake down. All of my equiptment was purchased new also. Plowing on a commercial base14-24 hours straight i dont feel they hold up. I seen 2 brand new E-60's out of the box not work. Since i bought a red one i go to work and not worry when i reach for the switch.
     
  19. DAZ982500

    DAZ982500 Senior Member
    Messages: 142

    Took "A" Valve out inspected filter, this was clean, however, I did spray Carb Cleaner on it.I put it all back together then inspected black wire connection.This was clean still had dielectric jelly on it cleaned it up.I will try this on Sunday with blade attached to determine if it works.If yes, maybe I have resolved the problem if No,:dizzy: I will be stumped and looking for answers.Stay tunned.Dave
     
  20. sefh

    sefh Senior Member
    Messages: 437

    Just a thought but has anyone tried spraying the connectors and wires with WD40? It works on spark plug wire to help get the moisture out. Just a thought :)