1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47 not moving?

Discussion in 'Truck & Equipment Repair' started by ogill2783, Jan 22, 2011.

  1. ogill2783

    ogill2783 Junior Member
    Messages: 14

    Ok I have an 88 dodge snow commander with a Meyers e47 pump that does nothing. I have replaced the power and negative wires all have good connections. I have replaced all the valves and they all magentas when engaged I have replaced the motor and hydro pump and it is working but I can't get the plow to lift. I have taken the plow off so don't know if it angles but it wouldn't when it was connected. I was wondering when I replaced the filters by the drain plug this morning should fluid have poured out when I removed the bolts? Cause it didn't. I'm thinking I have water frozen some where but as it is 8 out side and I have to garage to park it in is there any way to figure out if that's the reason things are not moving? Any help would be great!
     
  2. ogill2783

    ogill2783 Junior Member
    Messages: 14

    And also have replaced the solinoied.
     
  3. WetChicken

    WetChicken Senior Member
    Messages: 132

    If you had absolutely nothing come out when you took out the plugs, then it is frozen or it has no fluid in it.
    Park it inside overnight and then do a complete drain, flush, and refill.
     
  4. ogill2783

    ogill2783 Junior Member
    Messages: 14

    Its full and I have no where to park in side?
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Would be helpful if you knew whether it would angle or not but it's probably froze up. If you have no heated place to get the truck remove the pump from the truck and carry it inside to thaw out.