1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47 no power, solenoid not clicking

Discussion in 'Meyer / Diamond Products Discussion' started by 97S104x4, Nov 17, 2015.

  1. 97S104x4

    97S104x4 Senior Member
    Messages: 148

    I suspect a bad solenoid, but here's what I have done so far. If I take the power wire from the motor direct to battery the motor works as normal. I had power going into the solenoid, but when I would toggle the switch the solenoid doesn't click as it has always done before. It is grounded. When I attach the switched wire from the solenoid direct to the battery and toggle one direction, the corresponding wire at the pump has power. Signs of bad solenoid? Everything worked when it was put away last year


    Does anyone have a make and model car or truck I can tell them at the local auto parts store to see if they have this solenoid in stock?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,960

    Test light the small terminal of the solenoid while your operating U,L,R if the test light lights, the Ck the output side of the big terminals. I suspect you'll get nothing, but try for grins.
    IMO I'd go with a plow solenoid not an automotive one. And any plow manufacturers solenoid will work, just make sure if for "continuous" duty
     
  3. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,641

    Dual toggle switches or slik stik? Try pushing a little harder and wiggle the toggle switches. Also do as SS said and test for signal at the solenoid.
     
  4. jmassi

    jmassi Senior Member
    Messages: 154

    Make sure the solenoid is grounded good. Take it off and clean the ground and try again. A bad ground will cause you to go bats#*t crazy!