1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E47 moves left instead of right after 45 minutes

Discussion in 'Meyer / Diamond Products Discussion' started by leadfooter, Jan 11, 2011.

  1. leadfooter

    leadfooter Member
    from Midwest
    Messages: 49

    I have an old e47 and it works fine with a fresh charging of my battery but after about 1hr
    of plowing it will only move left when Im try to move it right. Up and down works fine though. Then I park it and charge it overnight and it all works fine again???
    What causes this??
    Thanks
     
    Last edited: Jan 11, 2011
  2. bigbricklayer

    bigbricklayer Junior Member
    Messages: 16

    I know if you don't have enough power to activate the C solanoid all your plow will do is angle left. I just had to replace my switch because my plow would go left but then wouldn't go back to the right. So my guess would be an electrical issue.
     
  3. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    the c coil is going bad. resistance increases with use until it won't function.
     
  4. leadfooter

    leadfooter Member
    from Midwest
    Messages: 49

    Thanks
    My C coil only has about 15 hrs of use on it since I replaced it ??
    So is the C coil running down my battery quicker as well??.... seems strange when its got a fresh charge in it the plow angles right and left just fine??
     
    Last edited: Jan 12, 2011
  5. 95trd

    95trd Junior Member
    from Pa
    Messages: 4

    I have a similar if not the same problem with mine, I hooked the plow up for the first storm and it worked great until I got home to do my own driveway and all it would do is angle left and drop, but while dropping it would slowly angle left. Then the next morning I fired my truck up and it worked for about 15 minutes then only angled left again. Some of the guys at work said to run a ground cable to all the solenoids and then ground it to the battery instead of just a clean spot on the frame, I havent tried it yet but its about the only thing I havent tried.
     
  6. Bashby

    Bashby Senior Member
    Messages: 228

    Sounds like you might have a problem with the charging system.