1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E 60 suck any help please......

Discussion in 'Meyer / Diamond Products Discussion' started by fxcars, Jan 8, 2011.

  1. fxcars

    fxcars Junior Member
    Messages: 8

    SO i have a e60 that will lift and angle left no problem.I had this problem before and took the pa block off cleaned it all out cleaned the crossover relief and replaced the O rings on all the valves and relief as well as cleaned the valves.I replaced the sol on the C valve it has 12 volts and still no right angle any ideas please? thanks
     
  2. LON

    LON Senior Member
    Messages: 749

    try swapping the hoses to see if it is hydraulic or mechanical issue.
     
  3. jmassi

    jmassi Senior Member
    Messages: 154

    Try replacing the couplers.
     
  4. fxcars

    fxcars Junior Member
    Messages: 8

    thank you for the help but still no go...I have a bad feeling it's the PA block.BIG $
     
  5. fordsuvparts

    fordsuvparts Senior Member
    Messages: 135

    Have you replaced the c-valve, you said you replaced the solenoid, did you mean the coil?

    The C-valves has a problem with swelling and locking up, the Cheap thing to replace is the c-valve first.
     
  6. fxcars

    fxcars Junior Member
    Messages: 8

    thanks

    so I'm happy to say it works again.....what did i do you ask? replaced the PA block.......