1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-60 Pump question, is this right???

Discussion in 'Meyer / Diamond Products Discussion' started by Mower For Less, Nov 7, 2005.

  1. Mower For Less

    Mower For Less Senior Member
    Messages: 108

    Hi,

    Upgraded my E-47 to an E-60. It appears to be working fine, but I wonder if this is normal. When The lifting ram is in any position (with no weight from a blade obviously) you can freely lift it to its maximum travel, and then freely push it back down to where it was. There is little to no resistance, and you can easily move it with one hand. It will hold its height for carrying, and will not push down any further than where it was when you manually lifted the ram, but it moves so freely it seems strange. I do not think my E-47 worked like that. I tore the E-60 down when I got it, and checked all the seals and packings, and everything looked good. Is there some kinda valve that might be sticking, or is that just how they are?

    Thanks
    Kevin
     
  2. Dwan

    Dwan Senior Member
    Messages: 879

    Just how they are. Nothy wrong with your e-60
     
  3. Mower For Less

    Mower For Less Senior Member
    Messages: 108

    Good to know. Thanks for the reply.