1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

E-60 Pump - Not going up

Discussion in 'Meyer / Diamond Products Discussion' started by Snow65, Dec 28, 2008.

  1. Snow65

    Snow65 Junior Member
    Messages: 10

    Any help would be appreciated here.

    I have a Meyer E-60 pump that will only click at the solenoid when I hit the up lever. It is a slick stick control.

    I replaced the solenoid but still get only a click when trying to lift the blade. The pump will not go up.

    Any suggestions ?

  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,990

    Check a clean all connections. You could have a second bad 12 volt motor soleniod seen it happen before.
  3. Clint S

    Clint S Senior Member
    Messages: 280

    Does it go left, right. I too have seen bad solenoids out of the box. Check for 12 volts at the solenoid, both posts with the button pushed. Then for 12 v at the motor with the button pushed. Check and tighten all grounds and 12 volt connections If you have the one post motor they are pretty finicky about good grounds. If motor you have 12 volts at the motor it may be time for a new one get the 2 post one with a dedicated ground. You can take the motor apart and clean then they do get some crud and condensation in there.